ALPINE-CVE-2021-41819
ALPINE-CVE-2021-41819
This page contains facts from public vulnerability sources. Check the original advisory before updating.
CGI::Cookie.parse in Ruby through 2.6.8 mishandles security prefixes in cookie names. This also affects the CGI gem through 0.3.0 for Ruby.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
ruby Alpine:v3.12
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.5-r0
Update to 2.7.5-r0
ruby Alpine:v3.13
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.5-r0
Update to 2.7.5-r0
ruby Alpine:v3.14
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.5-r0
Update to 2.7.5-r0
ruby Alpine:v3.15
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.0.3-r0
Update to 3.0.3-r0
ruby Alpine:v3.16
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.0.3-r0
Update to 3.0.3-r0
ruby Alpine:v3.17
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.0.3-r0
Update to 3.0.3-r0
ruby Alpine:v3.18
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.0.3-r0
Update to 3.0.3-r0
ruby Alpine:v3.19
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.0.3-r0
Update to 3.0.3-r0
ruby Alpine:v3.20
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.0.3-r0
Update to 3.0.3-r0
ruby Alpine:v3.21
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.0.3-r0
Update to 3.0.3-r0
ruby Alpine:v3.22
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.0.3-r0
Update to 3.0.3-r0
ruby Alpine:v3.23
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.0.3-r0
Update to 3.0.3-r0
ruby Alpine:v3.24
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.0.3-r0
Update to 3.0.3-r0