ALPINE-CVE-2022-22576
ALPINE-CVE-2022-22576
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An improper authentication vulnerability exists in curl 7.33.0 to and including 7.82.0 which might allow reuse OAUTH2-authenticated connections without properly making sure that the connection was authenticated with the same credentials as set for this transfer. This affects SASL-enabled protocols: SMPTP(S), IMAP(S), POP3(S) and LDAP(S) (openldap only).
CVSS 8.1 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
curl Alpine:v3.12
- Affected ranges
- ECOSYSTEM: ≥ 7.33.0, < 7.79.1-r1
Update to 7.79.1-r1
curl Alpine:v3.13
- Affected ranges
- ECOSYSTEM: ≥ 7.33.0, < 7.79.1-r1
Update to 7.79.1-r1
curl Alpine:v3.14
- Affected ranges
- ECOSYSTEM: ≥ 7.33.0, < 7.79.1-r1
Update to 7.79.1-r1
curl Alpine:v3.15
- Affected ranges
- ECOSYSTEM: ≥ 7.33.0, < 7.80.0-r1
Update to 7.80.0-r1
curl Alpine:v3.16
- Affected ranges
- ECOSYSTEM: ≥ 7.33.0, < 7.83.0-r0
Update to 7.83.0-r0
curl Alpine:v3.17
- Affected ranges
- ECOSYSTEM: ≥ 7.33.0, < 7.83.0-r0
Update to 7.83.0-r0
curl Alpine:v3.18
- Affected ranges
- ECOSYSTEM: ≥ 7.33.0, < 7.83.0-r0
Update to 7.83.0-r0
curl Alpine:v3.19
- Affected ranges
- ECOSYSTEM: ≥ 7.33.0, < 7.83.0-r0
Update to 7.83.0-r0
curl Alpine:v3.20
- Affected ranges
- ECOSYSTEM: ≥ 7.33.0, < 7.83.0-r0
Update to 7.83.0-r0
curl Alpine:v3.21
- Affected ranges
- ECOSYSTEM: ≥ 7.33.0, < 7.83.0-r0
Update to 7.83.0-r0
curl Alpine:v3.22
- Affected ranges
- ECOSYSTEM: ≥ 7.33.0, < 7.83.0-r0
Update to 7.83.0-r0
curl Alpine:v3.23
- Affected ranges
- ECOSYSTEM: ≥ 7.33.0, < 7.83.0-r0
Update to 7.83.0-r0
curl Alpine:v3.24
- Affected ranges
- ECOSYSTEM: ≥ 7.33.0, < 7.83.0-r0
Update to 7.83.0-r0