p PatchFirst

ALPINE-CVE-2022-27774

ALPINE-CVE-2022-27774

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An insufficiently protected credentials vulnerability exists in curl 4.9 to and include curl 7.82.0 are affected that could allow an attacker to extract credentials when follows HTTP(S) redirects is used with authentication could leak credentials to other services that exist on different protocols or port numbers.

CVSS 5.7 · Medium · Fix available

Published
Updated

Stack: system

Affected products and versions

  • curl Alpine:v3.12

    Affected ranges
    • ECOSYSTEM: ≥ 4.9, < 7.79.1-r1

    Update to 7.79.1-r1

  • curl Alpine:v3.13

    Affected ranges
    • ECOSYSTEM: ≥ 4.9, < 7.79.1-r1

    Update to 7.79.1-r1

  • curl Alpine:v3.14

    Affected ranges
    • ECOSYSTEM: ≥ 4.9, < 7.79.1-r1

    Update to 7.79.1-r1

  • curl Alpine:v3.15

    Affected ranges
    • ECOSYSTEM: ≥ 4.9, < 7.80.0-r1

    Update to 7.80.0-r1

  • curl Alpine:v3.16

    Affected ranges
    • ECOSYSTEM: ≥ 4.9, < 7.83.0-r0

    Update to 7.83.0-r0

  • curl Alpine:v3.17

    Affected ranges
    • ECOSYSTEM: ≥ 4.9, < 7.83.0-r0

    Update to 7.83.0-r0

  • curl Alpine:v3.18

    Affected ranges
    • ECOSYSTEM: ≥ 4.9, < 7.83.0-r0

    Update to 7.83.0-r0

  • curl Alpine:v3.19

    Affected ranges
    • ECOSYSTEM: ≥ 4.9, < 7.83.0-r0

    Update to 7.83.0-r0

  • curl Alpine:v3.20

    Affected ranges
    • ECOSYSTEM: ≥ 4.9, < 7.83.0-r0

    Update to 7.83.0-r0

  • curl Alpine:v3.21

    Affected ranges
    • ECOSYSTEM: ≥ 4.9, < 7.83.0-r0

    Update to 7.83.0-r0

  • curl Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: ≥ 4.9, < 7.83.0-r0

    Update to 7.83.0-r0

  • curl Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: ≥ 4.9, < 7.83.0-r0

    Update to 7.83.0-r0

  • curl Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: ≥ 4.9, < 7.83.0-r0

    Update to 7.83.0-r0

Original sources

Check your server →