ALPINE-CVE-2022-28739
ALPINE-CVE-2022-28739
This page contains facts from public vulnerability sources. Check the original advisory before updating.
There is a buffer over-read in Ruby before 2.6.10, 2.7.x before 2.7.6, 3.x before 3.0.4, and 3.1.x before 3.1.2. It occurs in String-to-Float conversion, including Kernel#Float and String#to_f.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
ruby Alpine:v3.12
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.6-r0
Update to 2.7.6-r0
ruby Alpine:v3.13
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.6-r0
Update to 2.7.6-r0
ruby Alpine:v3.14
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.6-r0
Update to 2.7.6-r0
ruby Alpine:v3.15
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.0.4-r0
Update to 3.0.4-r0
ruby Alpine:v3.16
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.1.2-r0
Update to 3.1.2-r0
ruby Alpine:v3.17
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.1.2-r0
Update to 3.1.2-r0
ruby Alpine:v3.18
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.1.2-r0
Update to 3.1.2-r0
ruby Alpine:v3.19
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.1.2-r0
Update to 3.1.2-r0
ruby Alpine:v3.20
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.1.2-r0
Update to 3.1.2-r0
ruby Alpine:v3.21
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.1.2-r0
Update to 3.1.2-r0
ruby Alpine:v3.22
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.1.2-r0
Update to 3.1.2-r0
ruby Alpine:v3.23
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.1.2-r0
Update to 3.1.2-r0
ruby Alpine:v3.24
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 3.1.2-r0
Update to 3.1.2-r0