ALPINE-CVE-2022-2881
ALPINE-CVE-2022-2881
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The underlying bug might cause read past end of the buffer and either read memory it should not read, or crash the process.
CVSS 8.2 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
bind Alpine:v3.13
- Affected ranges
- ECOSYSTEM: ≥ 9.18.0, < 9.16.33-r0
Update to 9.16.33-r0
bind Alpine:v3.14
- Affected ranges
- ECOSYSTEM: ≥ 9.18.0, < 9.16.33-r0
Update to 9.16.33-r0
bind Alpine:v3.15
- Affected ranges
- ECOSYSTEM: ≥ 9.18.0, < 9.16.33-r0
Update to 9.16.33-r0
bind Alpine:v3.16
- Affected ranges
- ECOSYSTEM: ≥ 9.18.0, < 9.16.33-r0
Update to 9.16.33-r0
bind Alpine:v3.17
- Affected ranges
- ECOSYSTEM: ≥ 9.18.0, < 9.18.7-r0
Update to 9.18.7-r0
bind Alpine:v3.18
- Affected ranges
- ECOSYSTEM: ≥ 9.18.0, < 9.18.7-r0
Update to 9.18.7-r0
bind Alpine:v3.19
- Affected ranges
- ECOSYSTEM: ≥ 9.18.0, < 9.18.7-r0
Update to 9.18.7-r0
bind Alpine:v3.20
- Affected ranges
- ECOSYSTEM: ≥ 9.18.0, < 9.18.7-r0
Update to 9.18.7-r0
bind Alpine:v3.21
- Affected ranges
- ECOSYSTEM: ≥ 9.18.0, < 9.18.7-r0
Update to 9.18.7-r0
bind Alpine:v3.22
- Affected ranges
- ECOSYSTEM: ≥ 9.18.0, < 9.18.7-r0
Update to 9.18.7-r0
bind Alpine:v3.23
- Affected ranges
- ECOSYSTEM: ≥ 9.18.0, < 9.18.7-r0
Update to 9.18.7-r0
bind Alpine:v3.24
- Affected ranges
- ECOSYSTEM: ≥ 9.18.0, < 9.18.7-r0
Update to 9.18.7-r0