ALPINE-CVE-2022-41741
ALPINE-CVE-2022-41741
This page contains facts from public vulnerability sources. Check the original advisory before updating.
NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to corrupt NGINX worker memory, resulting in its termination or potential other impact using a specially crafted audio or video file. The issue affects only NGINX products that are built with the ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video file with the module ngx_http_mp4_module.
CVSS 7.8 · High · Fix available
- Published
- Updated
Affected products and versions
nginx Alpine:v3.16
- Affected ranges
- ECOSYSTEM: ≥ 1.1.3, < 1.22.1-r0
Update to 1.22.1-r0
nginx Alpine:v3.17
- Affected ranges
- ECOSYSTEM: ≥ 1.1.3, < 1.22.1-r0
Update to 1.22.1-r0
nginx Alpine:v3.18
- Affected ranges
- ECOSYSTEM: ≥ 1.1.3, < 1.22.1-r0
Update to 1.22.1-r0
nginx Alpine:v3.19
- Affected ranges
- ECOSYSTEM: ≥ 1.1.3, < 1.22.1-r0
Update to 1.22.1-r0
nginx Alpine:v3.20
- Affected ranges
- ECOSYSTEM: ≥ 1.1.3, < 1.22.1-r0
Update to 1.22.1-r0
nginx Alpine:v3.21
- Affected ranges
- ECOSYSTEM: ≥ 1.1.3, < 1.22.1-r0
Update to 1.22.1-r0
nginx Alpine:v3.22
- Affected ranges
- ECOSYSTEM: ≥ 1.1.3, < 1.22.1-r0
Update to 1.22.1-r0
nginx Alpine:v3.23
- Affected ranges
- ECOSYSTEM: ≥ 1.1.3, < 1.22.1-r0
Update to 1.22.1-r0
nginx Alpine:v3.24
- Affected ranges
- ECOSYSTEM: ≥ 1.1.3, < 1.22.1-r0
Update to 1.22.1-r0