ALPINE-CVE-2022-43548
ALPINE-CVE-2022-43548
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A OS Command Injection vulnerability exists in Node.js versions <14.21.1, <16.18.1, <18.12.1, <19.0.1 due to an insufficient IsAllowedHost check that can easily be bypassed because IsIPAddress does not properly check if an IP address is invalid before making DBS requests allowing rebinding attacks.The fix for this issue in https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-32212 was incomplete and this new CVE is to complete the fix.
CVSS 8.1 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
nodejs Alpine:v3.17
- Affected ranges
- ECOSYSTEM: < 18.12.1-r0
Update to 18.12.1-r0
nodejs Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 18.12.1-r0
Update to 18.12.1-r0
nodejs Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 18.12.1-r0
Update to 18.12.1-r0
nodejs Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 18.12.1-r0
Update to 18.12.1-r0
nodejs Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 18.12.1-r0
Update to 18.12.1-r0
nodejs Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 18.12.1-r0
Update to 18.12.1-r0
nodejs Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 18.12.1-r0
Update to 18.12.1-r0
nodejs Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 18.12.1-r0
Update to 18.12.1-r0