p PatchFirst

ALPINE-CVE-2022-45060

ALPINE-CVE-2022-45060

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An HTTP Request Forgery issue was discovered in Varnish Cache 5.x and 6.x before 6.0.11, 7.x before 7.1.2, and 7.2.x before 7.2.1. An attacker may introduce characters through HTTP/2 pseudo-headers that are invalid in the context of an HTTP/1 request line, causing the Varnish server to produce invalid HTTP/1 requests to the backend. This could, in turn, be used to exploit vulnerabilities in a server behind the Varnish server. Note: the 6.0.x LTS series (before 6.0.11) is affected.

CVSS 7.5 · High · Fix available

Published
Updated

Stack: system

Affected products and versions

  • varnish Alpine:v3.17

    Affected ranges
    • ECOSYSTEM: < 7.2.1-r0

    Update to 7.2.1-r0

  • varnish Alpine:v3.18

    Affected ranges
    • ECOSYSTEM: < 7.2.1-r0

    Update to 7.2.1-r0

  • varnish Alpine:v3.19

    Affected ranges
    • ECOSYSTEM: < 7.2.1-r0

    Update to 7.2.1-r0

  • varnish Alpine:v3.20

    Affected ranges
    • ECOSYSTEM: < 7.2.1-r0

    Update to 7.2.1-r0

  • varnish Alpine:v3.21

    Affected ranges
    • ECOSYSTEM: < 7.2.1-r0

    Update to 7.2.1-r0

  • varnish Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: < 7.2.1-r0

    Update to 7.2.1-r0

  • varnish Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 7.2.1-r0

    Update to 7.2.1-r0

  • varnish Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: < 7.2.1-r0

    Update to 7.2.1-r0

Original sources

Check your server →