p PatchFirst

ALPINE-CVE-2024-0450

ALPINE-CVE-2024-0450

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was found in the CPython `zipfile` module affecting versions 3.12.1, 3.11.7, 3.10.13, 3.9.18, and 3.8.18 and prior. The zipfile module is vulnerable to “quoted-overlap” zip-bombs which exploit the zip format to create a zip-bomb with a high compression ratio. The fixed versions of CPython makes the zipfile module reject zip archives which overlap entries in the archive.

CVSS 6.2 · Medium · Fix available

Published
Updated

Stack: system

Affected products and versions

  • python3 Alpine:v3.16

    Affected ranges
    • ECOSYSTEM: < 3.10.14-r0

    Update to 3.10.14-r0

  • python3 Alpine:v3.17

    Affected ranges
    • ECOSYSTEM: < 3.10.14-r0

    Update to 3.10.14-r0

Original sources

Check your server →