ALPINE-CVE-2024-7347
ALPINE-CVE-2024-7347
This page contains facts from public vulnerability sources. Check the original advisory before updating.
NGINX Open Source and NGINX Plus have a vulnerability in the ngx_http_mp4_module, which might allow an attacker to over-read NGINX worker memory resulting in its termination, using a specially crafted mp4 file. The issue only affects NGINX if it is built with the ngx_http_mp4_module and the mp4 directive is used in the configuration file. Additionally, the attack is possible only if an attacker can trigger the processing of a specially crafted mp4 file with the ngx_http_mp4_module. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
CVSS 4.7 · Medium · Fix available
- Published
- Updated
Affected products and versions
nginx Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 1.26.2-r0
Update to 1.26.2-r0
nginx Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 1.26.2-r0
Update to 1.26.2-r0
nginx Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 1.26.2-r0
Update to 1.26.2-r0
nginx Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 1.26.2-r0
Update to 1.26.2-r0
nginx Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 1.26.2-r0
Update to 1.26.2-r0