p PatchFirst

ALPINE-CVE-2025-14104

ALPINE-CVE-2025-14104

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A flaw was found in util-linux. This vulnerability allows a heap buffer overread when processing 256-byte usernames, specifically within the `setpwnam()` function, affecting SUID (Set User ID) login-utils utilities writing to the password database.

CVSS 6.1 · Medium · Fix available

Published
Updated

Stack: system

Affected products and versions

  • util-linux Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: < 2.41.6-r0

    Update to 2.41.6-r0

  • util-linux Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 2.41.4-r0

    Update to 2.41.4-r0

Original sources

Check your server →