p PatchFirst

ALPINE-CVE-2025-53859

ALPINE-CVE-2025-53859

This page contains facts from public vulnerability sources. Check the original advisory before updating.

NGINX Open Source and NGINX Plus have a vulnerability in the ngx_mail_smtp_module that might allow an unauthenticated attacker to over-read NGINX SMTP authentication process memory; as a result, the server side may leak arbitrary bytes sent in a request to the authentication server. This issue happens during the NGINX SMTP authentication process and requires the attacker to make preparations against the target system to extract the leaked data. The issue affects NGINX only if (1) it is built with the ngx_mail_smtp_module, (2) the smtp_auth directive is configured with method "none," and (3) the authentication server returns the "Auth-Wait" response header. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

CVSS 6.3 · Medium · Fix available

Published
Updated

Stack: system · web

Affected products and versions

  • nginx Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: < 1.28.2-r0

    Update to 1.28.2-r0

  • nginx Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 1.28.2-r0

    Update to 1.28.2-r0

  • nginx Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: < 1.28.2-r0

    Update to 1.28.2-r0

Original sources

Check your server →