p PatchFirst

ALPINE-CVE-2026-110264

ALPINE-CVE-2026-110264

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered in GitLab CE/EE affecting all versions from 7.0 before 18.11.13, 19.0 before 19.0.10, 19.1 before 19.1.9, 19.2 before 19.2.9, 19.3 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server due to integer overflow when compiling a specially crafted regular expression.

CVSS 10.0 · Critical · Fix available

Published
Updated

Stack: system

Affected products and versions

  • ruby Alpine:v3.21

    Affected ranges
    • ECOSYSTEM: < 3.3.13-r0

    Update to 3.3.13-r0

  • ruby Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: < 3.4.12-r0

    Update to 3.4.12-r0

  • ruby Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 3.4.12-r0

    Update to 3.4.12-r0

  • ruby Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: < 3.4.12-r0

    Update to 3.4.12-r0

Original sources

Check your server →