p PatchFirst

ALPINE-CVE-2026-111497

ALPINE-CVE-2026-111497

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

CVSS 9.2 · Critical · Fix available

Published
Updated

Stack: system

Affected products and versions

  • brotli Alpine:v3.21

    Affected ranges
    • ECOSYSTEM: < 1.1.1-r0

    Update to 1.1.1-r0

  • brotli Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 1.2.1-r0

    Update to 1.2.1-r0

  • brotli Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: < 1.2.1-r0

    Update to 1.2.1-r0

Original sources

Check your server →