p PatchFirst

ALPINE-CVE-2026-27784

ALPINE-CVE-2026-27784

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The 32-bit implementation of NGINX Open Source has a vulnerability in the ngx_http_mp4_module module, which might allow an attacker to over-read or over-write NGINX worker memory resulting in its termination, using a specially crafted MP4 file. The issue only affects 32-bit NGINX Open Source if it is built with the ngx_http_mp4_module module and the mp4 directive is used in the configuration file. Additionally, the attack is possible only if an attacker can trigger the processing of a specially crafted MP4 file with the ngx_http_mp4_module module. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

CVSS 8.5 · High · Fix available

Published
Updated

Stack: system · web

Affected products and versions

  • nginx Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: < 1.28.3-r0

    Update to 1.28.3-r0

  • nginx Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 1.28.3-r0

    Update to 1.28.3-r0

  • nginx Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: < 1.28.3-r0

    Update to 1.28.3-r0

Original sources

Check your server →