p PatchFirst

ALPINE-CVE-2026-28755

ALPINE-CVE-2026-28755

This page contains facts from public vulnerability sources. Check the original advisory before updating.

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_stream_ssl_module module due to the improper handling of revoked certificates when configured with the ssl_verify_client on and ssl_ocsp on directives, allowing the TLS handshake to succeed even after an OCSP check identifies the certificate as revoked.   Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

CVSS 5.4 · Medium · Fix available

Published
Updated

Stack: system · web

Affected products and versions

  • nginx Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: < 1.28.3-r0

    Update to 1.28.3-r0

  • nginx Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 1.28.3-r0

    Update to 1.28.3-r0

  • nginx Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: < 1.28.3-r0

    Update to 1.28.3-r0

Original sources

Check your server →