p PatchFirst

ALPINE-CVE-2026-40701

ALPINE-CVE-2026-40701

This page contains facts from public vulnerability sources. Check the original advisory before updating.

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_ssl_module module when the ssl_verify_client directive is set to "on" or "optional," and the ssl_ocsp directive is set to "on" or the leaf parameters are configured with a resolver. With this configuration, an unauthenticated attacker can send requests along with conditions beyond its control that may cause a heap-use-after-free error in the NGINX worker process. This vulnerability may result in limited modification of data or the NGINX worker process restarting.  Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

CVSS 6.3 · Medium · Fix available

Published
Updated

Stack: system · web

Affected products and versions

  • nginx Alpine:v3.21

    Affected ranges
    • ECOSYSTEM: < 1.26.3-r1

    Update to 1.26.3-r1

  • nginx Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: < 1.28.3-r1

    Update to 1.28.3-r1

  • nginx Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 1.28.3-r1

    Update to 1.28.3-r1

Original sources

Check your server →