p PatchFirst

ALPINE-CVE-2026-41292

ALPINE-CVE-2026-41292

This page contains facts from public vulnerability sources. Check the original advisory before updating.

NLnet Labs Unbound up to and including version 1.25.0 is vulnerable to a degradation of service attack related to parsing long lists of incoming EDNS options. An adversary sending queries with too many EDNS options can hold Unbound threads hostage while they are parsing and creating internal data structures for the options. Coordinated attacks can result in degradation and/or denial of service. Unbound 1.25.1 contains a patch with a fix to limit acceptable incoming EDNS options (100).

CVSS 7.5 · High · Fix available

Published
Updated

Stack: system

Affected products and versions

  • unbound Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: < 1.25.2-r0

    Update to 1.25.2-r0

  • unbound Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 1.25.2-r0

    Update to 1.25.2-r0

  • unbound Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: < 1.25.1-r0

    Update to 1.25.1-r0

Original sources

Check your server →