p PatchFirst

ALPINE-CVE-2026-42055

ALPINE-CVE-2026-42055

This page contains facts from public vulnerability sources. Check the original advisory before updating.

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_proxy_v2_module and ngx_http_grpc_module modules. This vulnerability exists when the proxy_http_version to 2 or grpc_pass directives are used to proxy HTTP/2 traffic, the ignore_invalid_headers directive is set to off, and the large_client_header_buffers directive size is larger than 2 megabytes. A remote, unauthenticated attacker, along with conditions beyond their control, could send large headers while creating an upstream request. This may cause a heap-based buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

CVSS 9.2 · Critical · Fix available

Published
Updated

Stack: system · web

Affected products and versions

  • nginx Alpine:v3.21

    Affected ranges
    • ECOSYSTEM: < 1.26.3-r2

    Update to 1.26.3-r2

  • nginx Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: < 1.28.3-r4

    Update to 1.28.3-r4

  • nginx Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 1.28.3-r4

    Update to 1.28.3-r4

  • nginx Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: < 1.30.3-r0

    Update to 1.30.3-r0

Original sources

Check your server →