p PatchFirst

ALPINE-CVE-2026-42934

ALPINE-CVE-2026-42934

This page contains facts from public vulnerability sources. Check the original advisory before updating.

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_charset_module module. When charset, source_charset, and charset_map and proxy_pass with disabled buffering ("off") directives are configured, unauthenticated attackers can send requests that with conditions beyond the attackers' control to cause a heap buffer over-read in the NGINX worker process, leading to limited disclosure of memory or a restart.  Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

CVSS 6.3 · Medium · Fix available

Published
Updated

Stack: system · web

Affected products and versions

  • nginx Alpine:v3.21

    Affected ranges
    • ECOSYSTEM: < 1.26.3-r1

    Update to 1.26.3-r1

  • nginx Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: < 1.28.3-r1

    Update to 1.28.3-r1

  • nginx Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 1.28.3-r1

    Update to 1.28.3-r1

  • nginx Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: < 1.30.1-r0

    Update to 1.30.1-r0

Original sources

Check your server →