p PatchFirst

ALPINE-CVE-2026-42945

ALPINE-CVE-2026-42945

This page contains facts from public vulnerability sources. Check the original advisory before updating.

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_rewrite_module module. This vulnerability exists when the rewrite directive is followed by a rewrite, if, or set directive and an unnamed Perl-Compatible Regular Expression (PCRE) capture (for example, $1, $2) with a replacement string that includes a question mark (?). An unauthenticated attacker along with conditions beyond its control can exploit this vulnerability by sending crafted HTTP requests. This may cause a heap buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR.  Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

CVSS 9.2 · Critical · Fix available

Published
Updated

Stack: system · web

Affected products and versions

  • nginx Alpine:v3.21

    Affected ranges
    • ECOSYSTEM: < 1.26.3-r1

    Update to 1.26.3-r1

  • nginx Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: < 1.28.3-r1

    Update to 1.28.3-r1

  • nginx Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 1.28.3-r1

    Update to 1.28.3-r1

  • nginx Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: < 1.30.1-r0

    Update to 1.30.1-r0

Original sources

Check your server →