p PatchFirst

ALPINE-CVE-2026-60005

ALPINE-CVE-2026-60005

This page contains facts from public vulnerability sources. Check the original advisory before updating.

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_slice_module module. When the slice directive and unnamed regex captures are configured or when a background cache update happens, unauthenticated attackers can send requests that may cause uninitialized memory access in the NGINX worker process, leading to limited disclosure of memory or a restart. Impact: This vulnerability may allow remote, unauthenticated attackers to have limited control to disclose memory contents or restart the NGINX worker process. There is no control plane exposure; this is a data plane issue only. Note: The ngx_http_slice_module module is not enabled by default; it's enabled with the --with-http_slice_module configuration parameter. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

CVSS 8.2 · High · Fix available

Published
Updated

Stack: system · web

Affected products and versions

  • nginx Alpine:v3.21

    Affected ranges
    • ECOSYSTEM: < 1.26.3-r2

    Update to 1.26.3-r2

  • nginx Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: < 1.28.3-r6

    Update to 1.28.3-r6

  • nginx Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 1.28.3-r6

    Update to 1.28.3-r6

  • nginx Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: < 1.30.4-r0

    Update to 1.30.4-r0

Original sources

Check your server →