p PatchFirst

ALPINE-CVE-2026-95101

ALPINE-CVE-2026-95101

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Description NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_v3_module module. When using HTTP/3 with proxy_request_buffering on directive, an unauthenticated attacker may be able to inject data in the proxied request. Impact This vulnerability may allow remote attackers to inject data in the proxied request.  There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

CVSS 6.9 · Medium · Fix available

Published
Updated

Stack: system · web

Affected products and versions

  • nginx Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: < 1.30.6-r0

    Update to 1.30.6-r0

Original sources

Check your server →