p PatchFirst

PatchFirst · Latest vulnerabilities

curl vulnerabilities · Page 4

Vulnerabilities published for curl in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 67

  1. ALPINE-CVE-2016-7167

    Critical · CVSS 9.8Fix available

    ALPINE-CVE-2016-7167

    Multiple integer overflows in the (1) curl_escape, (2) curl_easy_escape, (3) curl_unescape, and (4) curl_easy_unescape functions in libcurl before 7.50.3 allow attackers to have unspecified impact via a string of length 0xffffffff, which triggers a heap-based buffer overflow.

    • Update to 7.50.3-r0
    Published Updated
  2. ALPINE-CVE-2016-7141

    High · CVSS 7.5Fix available

    ALPINE-CVE-2016-7141

    curl and libcurl before 7.50.2, when built with NSS and the libnsspem.so library is available at runtime, allow remote attackers to hijack the authentication of a TLS connection by leveraging reuse of a previously loaded client certificate from file for a connection for which no certificate has been set, a different vulnerability than CVE-2016-5420.

    • Update to 7.50.2-r0
    Published Updated
  3. ALPINE-CVE-2016-5420

    High · CVSS 7.5Fix available

    ALPINE-CVE-2016-5420

    curl and libcurl before 7.50.1 do not check the client certificate when choosing the TLS connection to reuse, which might allow remote attackers to hijack the authentication of the connection by leveraging a previously created connection with a different client certificate.

    • Update to 7.50.1-r0
    Published Updated
  4. ALPINE-CVE-2014-0139

    Not ratedFix available

    ALPINE-CVE-2014-0139

    cURL and libcurl 7.1 before 7.36.0, when using the OpenSSL, axtls, qsossl or gskit libraries for TLS, recognize a wildcard IP address in the subject's Common Name (CN) field of an X.509 certificate, which might allow man-in-the-middle attackers to spoof arbitrary SSL servers via a crafted certificate issued by a legitimate Certification Authority.

    • Update to 7.36.0-r0
    Published Updated
  5. ALPINE-CVE-2014-0138

    Not ratedFix available

    ALPINE-CVE-2014-0138

    The default configuration in cURL and libcurl 7.10.6 before 7.36.0 re-uses (1) SCP, (2) SFTP, (3) POP3, (4) POP3S, (5) IMAP, (6) IMAPS, (7) SMTP, (8) SMTPS, (9) LDAP, and (10) LDAPS connections, which might allow context-dependent attackers to connect as other users via a request, a similar issue to CVE-2014-0015.

    • Update to 7.36.0-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →