p PatchFirst

PatchFirst · Latest vulnerabilities

bind vulnerabilities · Page 3

Vulnerabilities published for bind in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 48

  1. ALPINE-CVE-2018-5736

    Medium · CVSS 5.3Fix available

    ALPINE-CVE-2018-5736

    An error in zone database reference counting can lead to an assertion failure if a server which is running an affected version of BIND attempts several transfers of a slave zone in quick succession. This defect could be deliberately exercised by an attacker who is permitted to cause a vulnerable server to initiate zone transfers (for example: by sending valid NOTIFY messages), causing the named process to exit after failing the assertion test. Affects BIND 9.12.0 and 9.12.1.

    • Update to 9.12.1_p2-r0
    Published Updated
  2. ALPINE-CVE-2017-3145

    High · CVSS 7.5Fix available

    ALPINE-CVE-2017-3145

    BIND was improperly sequencing cleanup operations on upstream recursion fetch contexts, leading in some cases to a use-after-free error that can trigger an assertion failure and crash in named. Affects BIND 9.0.0 to 9.8.x, 9.9.0 to 9.9.11, 9.10.0 to 9.10.6, 9.11.0 to 9.11.2, 9.9.3-S1 to 9.9.11-S1, 9.10.5-S1 to 9.10.6-S1, 9.12.0a1 to 9.12.0rc1.

    • Update to 9.11.2_p1-r0
    Published Updated
  3. ALPINE-CVE-2017-3138

    Medium · CVSS 5.3Fix available

    ALPINE-CVE-2017-3138

    named contains a feature which allows operators to issue commands to a running server by communicating with the server process over a control channel, using a utility program such as rndc. A regression introduced in a recent feature change has created a situation under which some versions of named can be caused to exit with a REQUIRE assertion failure if they are sent a null command string. Affects BIND 9.9.9->9.9.9-P7, 9.9.10b1->9.9.10rc2, 9.10.4->9.10.4-P7, 9.10.5b1->9.10.5rc2, 9.11.0->9.11.0-P4, 9.11.1b1->9.11.1rc2, 9.9.9-S1->9.9.9-S9.

    • Update to 9.11.0_p5-r0
    Published Updated
  4. ALPINE-CVE-2017-3137

    High · CVSS 7.5Fix available

    ALPINE-CVE-2017-3137

    Mistaken assumptions about the ordering of records in the answer section of a response containing CNAME or DNAME resource records could lead to a situation in which named would exit with an assertion failure when processing a response in which records occurred in an unusual order. Affects BIND 9.9.9-P6, 9.9.10b1->9.9.10rc1, 9.10.4-P6, 9.10.5b1->9.10.5rc1, 9.11.0-P3, 9.11.1b1->9.11.1rc1, and 9.9.9-S8.

    • Update to 9.11.0_p5-r0
    Published Updated
  5. ALPINE-CVE-2017-3136

    Medium · CVSS 5.9Fix available

    ALPINE-CVE-2017-3136

    A query with a specific set of characteristics could cause a server using DNS64 to encounter an assertion failure and terminate. An attacker could deliberately construct a query, enabling denial-of-service against a server if it was configured to use the DNS64 feature and other preconditions were met. Affects BIND 9.8.0 -> 9.8.8-P1, 9.9.0 -> 9.9.9-P6, 9.9.10b1->9.9.10rc1, 9.10.0 -> 9.10.4-P6, 9.10.5b1->9.10.5rc1, 9.11.0 -> 9.11.0-P3, 9.11.1b1->9.11.1rc1, 9.9.3-S1 -> 9.9.9-S8.

    • Update to 9.11.0_p5-r0
    Published Updated
  6. ALPINE-CVE-2016-9444

    High · CVSS 7.5Fix available

    ALPINE-CVE-2016-9444

    named in ISC BIND 9.x before 9.9.9-P5, 9.10.x before 9.10.4-P5, and 9.11.x before 9.11.0-P2 allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a crafted DS resource record in an answer.

    • Update to 9.10.4_p5-r0
    Published Updated
  7. ALPINE-CVE-2016-9147

    High · CVSS 7.5Fix available

    ALPINE-CVE-2016-9147

    named in ISC BIND 9.9.9-P4, 9.9.9-S6, 9.10.4-P4, and 9.11.0-P1 allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a response containing an inconsistency among the DNSSEC-related RRsets.

    • Update to 9.10.4_p5-r0
    Published Updated
  8. ALPINE-CVE-2016-9131

    High · CVSS 7.5Fix available

    ALPINE-CVE-2016-9131

    named in ISC BIND 9.x before 9.9.9-P5, 9.10.x before 9.10.4-P5, and 9.11.x before 9.11.0-P2 allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a malformed response to an RTYPE ANY query.

    • Update to 9.10.4_p5-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →