ALSA-2021:1586
ALSA-2021:1586 · Moderate: GNOME security, bug fix, and enhancement update
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
GNOME is the default desktop environment of AlmaLinux. The following packages have been upgraded to a later upstream version: accountsservice (0.6.55), webkit2gtk3 (2.30.4). (BZ#1846376, BZ#1883304) Security Fix(es): * webkitgtk: type confusion may lead to arbitrary code execution (CVE-2020-9948) * webkitgtk: use-after-free may lead to arbitrary code execution (CVE-2020-9951) * webkitgtk: out-of-bounds write may lead to code execution (CVE-2020-9983) * webkitgtk: use-after-free may lead to arbitrary code execution (CVE-2020-13543) * webkitgtk: use-after-free may lead to arbitrary code execution (CVE-2020-13584) * glib2: insecure permissions for files and directories (CVE-2019-13012) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section. Additional Changes: For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
openexr-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.2.0-12.el8
Update to 2.2.0-12.el8
openexr-libs AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.2.0-12.el8
Update to 2.2.0-12.el8
accountsservice-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 0.6.55-1.el8
Update to 0.6.55-1.el8
atkmm AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.24.2-7.el8
Update to 2.24.2-7.el8
atkmm-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.24.2-7.el8
Update to 2.24.2-7.el8
atkmm-doc AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.24.2-7.el8
Update to 2.24.2-7.el8
cairomm AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1.12.0-8.el8
Update to 1.12.0-8.el8
cairomm-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1.12.0-8.el8
Update to 1.12.0-8.el8
cairomm-doc AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1.12.0-8.el8
Update to 1.12.0-8.el8
chrome-gnome-shell AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 10.1-7.el8
Update to 10.1-7.el8
dleyna-core AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 0.6.0-3.el8
Update to 0.6.0-3.el8
dleyna-server AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 0.6.0-3.el8
Update to 0.6.0-3.el8
enchant2 AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.2.3-3.el8
Update to 2.2.3-3.el8
enchant2-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.2.3-3.el8
Update to 2.2.3-3.el8
gamin AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 0.1.10-32.el8
Update to 0.1.10-32.el8
gamin-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 0.1.10-32.el8
Update to 0.1.10-32.el8
geoclue2 AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.5.5-2.el8
Update to 2.5.5-2.el8
geoclue2-demos AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.5.5-2.el8
Update to 2.5.5-2.el8
geoclue2-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.5.5-2.el8
Update to 2.5.5-2.el8
geoclue2-libs AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.5.5-2.el8
Update to 2.5.5-2.el8
geocode-glib AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 3.26.0-3.el8
Update to 3.26.0-3.el8
geocode-glib-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 3.26.0-3.el8
Update to 3.26.0-3.el8
gjs AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1.56.2-5.el8
Update to 1.56.2-5.el8
gjs-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1.56.2-5.el8
Update to 1.56.2-5.el8
Original sources
- https://errata.almalinux.org/8/ALSA-2021-1586.html
- https://vulners.com/cve/CVE-2019-13012
- https://vulners.com/cve/CVE-2020-13543
- https://vulners.com/cve/CVE-2020-13584
- https://vulners.com/cve/CVE-2020-16125
- https://vulners.com/cve/CVE-2020-9948
- https://vulners.com/cve/CVE-2020-9951
- https://vulners.com/cve/CVE-2020-9983
- https://vulners.com/cve/CVE-2021-1817
- https://vulners.com/cve/CVE-2021-1820
- https://vulners.com/cve/CVE-2021-1825
- https://vulners.com/cve/CVE-2021-1826
- https://vulners.com/cve/CVE-2021-30661
- https://osv.dev/vulnerability/ALSA-2021:1586