ALSA-2022:4796
ALSA-2022:4796 · Important: nodejs:16 security update
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language. Security Fix(es): * npm: npm ci succeeds when package-lock.json doesn't match package.json (CVE-2021-43616) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
nodejs AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:16.14.0-4.module_el8.6.0+2904+f21ad6f4
Update to 1:16.14.0-4.module_el8.6.0+2904+f21ad6f4
nodejs-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:16.14.0-4.module_el8.6.0+2904+f21ad6f4
Update to 1:16.14.0-4.module_el8.6.0+2904+f21ad6f4
nodejs-docs AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:16.14.0-4.module_el8.6.0+2904+f21ad6f4
Update to 1:16.14.0-4.module_el8.6.0+2904+f21ad6f4
nodejs-full-i18n AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:16.14.0-4.module_el8.6.0+2904+f21ad6f4
Update to 1:16.14.0-4.module_el8.6.0+2904+f21ad6f4
nodejs-nodemon AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.0.15-1.module_el8.6.0+2904+f21ad6f4
Update to 2.0.15-1.module_el8.6.0+2904+f21ad6f4
nodejs-nodemon AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.0.15-1.module_el8.5.0+2605+45d748af
Update to 2.0.15-1.module_el8.5.0+2605+45d748af
nodejs-packaging AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 25-1.module_el8.5.0+246+05401605
Update to 25-1.module_el8.5.0+246+05401605
nodejs-packaging AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 25-1.module_el8.5.0+2605+45d748af
Update to 25-1.module_el8.5.0+2605+45d748af
npm AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:8.3.1-1.16.14.0.4.module_el8.6.0+2904+f21ad6f4
Update to 1:8.3.1-1.16.14.0.4.module_el8.6.0+2904+f21ad6f4