ALSA-2023:5363
ALSA-2023:5363 · Important: nodejs:18 security, bug fix, and enhancement update
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language. The following packages have been upgraded to a later upstream version: nodejs (18). (BZ#2223313, BZ#2234404) Security Fix(es): * nodejs: Permissions policies can be bypassed via Module._load (CVE-2023-32002) * nodejs-semver: Regular expression denial of service (CVE-2022-25883) * nodejs: Permissions policies can impersonate other modules in using module.constructor.createRequire() (CVE-2023-32006) * nodejs: Permissions policies can be bypassed via process.binding (CVE-2023-32559) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
nodejs AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 1:18.17.1-1.module_el9.2.0+36+853e48f5
Update to 1:18.17.1-1.module_el9.2.0+36+853e48f5
nodejs-devel AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 1:18.17.1-1.module_el9.2.0+36+853e48f5
Update to 1:18.17.1-1.module_el9.2.0+36+853e48f5
nodejs-docs AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 1:18.17.1-1.module_el9.2.0+36+853e48f5
Update to 1:18.17.1-1.module_el9.2.0+36+853e48f5
nodejs-full-i18n AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 1:18.17.1-1.module_el9.2.0+36+853e48f5
Update to 1:18.17.1-1.module_el9.2.0+36+853e48f5
nodejs-nodemon AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 3.0.1-1.module_el9.2.0+36+853e48f5
Update to 3.0.1-1.module_el9.2.0+36+853e48f5
nodejs-packaging AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 2021.06-4.module_el9.1.0+13+d9a595ea
Update to 2021.06-4.module_el9.1.0+13+d9a595ea
nodejs-packaging-bundler AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 2021.06-4.module_el9.1.0+13+d9a595ea
Update to 2021.06-4.module_el9.1.0+13+d9a595ea
npm AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 1:9.6.7-1.18.17.1.1.module_el9.2.0+36+853e48f5
Update to 1:9.6.7-1.18.17.1.1.module_el9.2.0+36+853e48f5
Original sources
- https://access.redhat.com/errata/RHSA-2023:5363
- https://access.redhat.com/security/cve/CVE-2022-25883
- https://access.redhat.com/security/cve/CVE-2023-32002
- https://access.redhat.com/security/cve/CVE-2023-32006
- https://access.redhat.com/security/cve/CVE-2023-32559
- https://bugzilla.redhat.com/2216475
- https://bugzilla.redhat.com/2230948
- https://bugzilla.redhat.com/2230955
- https://bugzilla.redhat.com/2230956
- https://errata.almalinux.org/9/ALSA-2023-5363.html
- https://osv.dev/vulnerability/ALSA-2023:5363