ALSA-2023:5709
ALSA-2023:5709 · Important: dotnet7.0 security update
This page contains facts from public vulnerability sources. Check the original advisory before updating.
.NET is a managed-software framework. It implements a subset of the .NET framework APIs and several new APIs, and it includes a CLR implementation. New versions of .NET that address a security vulnerability are now available. The updated versions are .NET 7.0 to SDK 7.0.112 and Runtime 7.0.12. Security Fix(es): * HTTP/2: Multiple HTTP/2 enabled web servers are vulnerable to a DDoS attack (Rapid Reset Attack) (CVE-2023-44487) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
aspnetcore-runtime-7.0 AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 7.0.12-1.el8_8
Update to 7.0.12-1.el8_8
aspnetcore-targeting-pack-7.0 AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 7.0.12-1.el8_8
Update to 7.0.12-1.el8_8
dotnet AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 7.0.112-1.el8_8
Update to 7.0.112-1.el8_8
dotnet-apphost-pack-7.0 AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 7.0.12-1.el8_8
Update to 7.0.12-1.el8_8
dotnet-host AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 7.0.12-1.el8_8
Update to 7.0.12-1.el8_8
dotnet-hostfxr-7.0 AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 7.0.12-1.el8_8
Update to 7.0.12-1.el8_8
dotnet-runtime-7.0 AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 7.0.12-1.el8_8
Update to 7.0.12-1.el8_8
dotnet-sdk-7.0 AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 7.0.112-1.el8_8
Update to 7.0.112-1.el8_8
dotnet-sdk-7.0-source-built-artifacts AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 7.0.112-1.el8_8
Update to 7.0.112-1.el8_8
dotnet-targeting-pack-7.0 AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 7.0.12-1.el8_8
Update to 7.0.12-1.el8_8
dotnet-templates-7.0 AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 7.0.112-1.el8_8
Update to 7.0.112-1.el8_8
netstandard-targeting-pack-2.1 AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 7.0.112-1.el8_8
Update to 7.0.112-1.el8_8