ALSA-2024:1687
ALSA-2024:1687 · Important: nodejs:20 security update
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language. Security Fix(es): * nodejs: vulnerable to timing variant of the Bleichenbacher attack against PKCS#1 v1.5 padding (Marvin) (CVE-2023-46809) * nodejs: reading unprocessed HTTP request with unbounded chunk extension allows DoS attacks (CVE-2024-22019) * nodejs: code injection and privilege escalation through Linux capabilities (CVE-2024-21892) * nodejs: path traversal by monkey-patching buffer internals (CVE-2024-21896) * nodejs: multiple permission model bypasses due to improper path traversal sequence sanitization (CVE-2024-21891) * nodejs: improper handling of wildcards in --allow-fs-read and --allow-fs-write (CVE-2024-21890) * nodejs: setuid() does not drop all privileges due to io_uring (CVE-2024-22017)
Fix available
- Published
- Updated
Stack: system
Affected products and versions
nodejs AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:20.11.1-1.module_el8.9.0+3775+d8460d35
Update to 1:20.11.1-1.module_el8.9.0+3775+d8460d35
nodejs-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:20.11.1-1.module_el8.9.0+3775+d8460d35
Update to 1:20.11.1-1.module_el8.9.0+3775+d8460d35
nodejs-docs AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:20.11.1-1.module_el8.9.0+3775+d8460d35
Update to 1:20.11.1-1.module_el8.9.0+3775+d8460d35
nodejs-full-i18n AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:20.11.1-1.module_el8.9.0+3775+d8460d35
Update to 1:20.11.1-1.module_el8.9.0+3775+d8460d35
nodejs-nodemon AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 3.0.1-1.module_el8.9.0+3731+490e3ce5
Update to 3.0.1-1.module_el8.9.0+3731+490e3ce5
nodejs-packaging AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2021.06-4.module_el8.9.0+3684+11b9e959
Update to 2021.06-4.module_el8.9.0+3684+11b9e959
nodejs-packaging-bundler AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2021.06-4.module_el8.9.0+3684+11b9e959
Update to 2021.06-4.module_el8.9.0+3684+11b9e959
npm AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:10.2.4-1.20.11.1.1.module_el8.9.0+3775+d8460d35
Update to 1:10.2.4-1.20.11.1.1.module_el8.9.0+3775+d8460d35
Original sources
- https://access.redhat.com/errata/RHSA-2024:1687
- https://access.redhat.com/security/cve/CVE-2023-46809
- https://access.redhat.com/security/cve/CVE-2024-21890
- https://access.redhat.com/security/cve/CVE-2024-21891
- https://access.redhat.com/security/cve/CVE-2024-21892
- https://access.redhat.com/security/cve/CVE-2024-21896
- https://access.redhat.com/security/cve/CVE-2024-22017
- https://access.redhat.com/security/cve/CVE-2024-22019
- https://bugzilla.redhat.com/2264569
- https://bugzilla.redhat.com/2264574
- https://bugzilla.redhat.com/2264582
- https://bugzilla.redhat.com/2265717
- https://bugzilla.redhat.com/2265720
- https://bugzilla.redhat.com/2265722
- https://bugzilla.redhat.com/2265727
- https://errata.almalinux.org/8/ALSA-2024-1687.html
- https://osv.dev/vulnerability/ALSA-2024:1687