ALSA-2024:3121
ALSA-2024:3121 · Moderate: httpd:2.4 security update
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The httpd packages provide the Apache HTTP Server, a powerful, efficient, and extensible web server. Security Fix(es): * httpd: mod_macro: out-of-bounds read vulnerability (CVE-2023-31122) * mod_http2: reset requests exhaust memory (incomplete fix of CVE-2023-44487) (CVE-2023-45802) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section. Additional Changes: For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
httpd AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.4.37-64.module_el8.10.0+3761+75f8c656
Update to 2.4.37-64.module_el8.10.0+3761+75f8c656
httpd-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.4.37-64.module_el8.10.0+3761+75f8c656
Update to 2.4.37-64.module_el8.10.0+3761+75f8c656
httpd-filesystem AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.4.37-64.module_el8.10.0+3761+75f8c656
Update to 2.4.37-64.module_el8.10.0+3761+75f8c656
httpd-manual AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.4.37-64.module_el8.10.0+3761+75f8c656
Update to 2.4.37-64.module_el8.10.0+3761+75f8c656
httpd-tools AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.4.37-64.module_el8.10.0+3761+75f8c656
Update to 2.4.37-64.module_el8.10.0+3761+75f8c656
mod_http2 AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1.15.7-10.module_el8.10.0+3832+564e7653
Update to 1.15.7-10.module_el8.10.0+3832+564e7653
mod_ldap AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.4.37-64.module_el8.10.0+3761+75f8c656
Update to 2.4.37-64.module_el8.10.0+3761+75f8c656
mod_md AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:2.0.8-8.module_el8.6.0+2872+fe0ff7aa
Update to 1:2.0.8-8.module_el8.6.0+2872+fe0ff7aa
mod_md AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:2.0.8-8.module_el8.6.0+3031+fb177b09
Update to 1:2.0.8-8.module_el8.6.0+3031+fb177b09
mod_proxy_html AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:2.4.37-64.module_el8.10.0+3761+75f8c656
Update to 1:2.4.37-64.module_el8.10.0+3761+75f8c656
mod_session AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.4.37-64.module_el8.10.0+3761+75f8c656
Update to 2.4.37-64.module_el8.10.0+3761+75f8c656
mod_ssl AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:2.4.37-64.module_el8.10.0+3761+75f8c656
Update to 1:2.4.37-64.module_el8.10.0+3761+75f8c656
Original sources
- https://access.redhat.com/errata/RHSA-2024:3121
- https://access.redhat.com/security/cve/CVE-2023-31122
- https://access.redhat.com/security/cve/CVE-2023-45802
- https://bugzilla.redhat.com/2243877
- https://bugzilla.redhat.com/2245332
- https://errata.almalinux.org/8/ALSA-2024-3121.html
- https://osv.dev/vulnerability/ALSA-2024:3121