ALSA-2025:15095
ALSA-2025:15095 · Moderate: httpd security update
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The httpd packages provide the Apache HTTP Server, a powerful, efficient, and extensible web server. Security Fix(es): * httpd: insufficient escaping of user-supplied data in mod_ssl (CVE-2024-47252) * httpd: mod_ssl: access control bypass by trusted clients is possible using TLS 1.3 session resumption (CVE-2025-23048) * httpd: HTTP Session Hijack via a TLS upgrade (CVE-2025-49812) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
httpd-filesystem AlmaLinux:10
- Affected ranges
- ECOSYSTEM: < 2.4.63-1.el10_0.2
Update to 2.4.63-1.el10_0.2
httpd-manual AlmaLinux:10
- Affected ranges
- ECOSYSTEM: < 2.4.63-1.el10_0.2
Update to 2.4.63-1.el10_0.2
Original sources
- https://access.redhat.com/errata/RHSA-2025:15095
- https://access.redhat.com/security/cve/CVE-2024-47252
- https://access.redhat.com/security/cve/CVE-2025-23048
- https://access.redhat.com/security/cve/CVE-2025-49812
- https://bugzilla.redhat.com/2374571
- https://bugzilla.redhat.com/2374576
- https://bugzilla.redhat.com/2374580
- https://errata.almalinux.org/10/ALSA-2025-15095.html
- https://osv.dev/vulnerability/ALSA-2025:15095