ALSA-2025:15123
ALSA-2025:15123 · Moderate: httpd:2.4 security update
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The httpd packages provide the Apache HTTP Server, a powerful, efficient, and extensible web server. Security Fix(es): * httpd: insufficient escaping of user-supplied data in mod_ssl (CVE-2024-47252) * httpd: mod_ssl: access control bypass by trusted clients is possible using TLS 1.3 session resumption (CVE-2025-23048) * httpd: mod_proxy_http2: untrusted input from a client causes an assertion to fail in the Apache mod_proxy_http2 module (CVE-2025-49630) * httpd: HTTP Session Hijack via a TLS upgrade (CVE-2025-49812) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
httpd AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
Update to 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
httpd-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
Update to 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
httpd-filesystem AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
Update to 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
httpd-manual AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
Update to 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
httpd-tools AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
Update to 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
mod_http2 AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1.15.7-10.module_el8.10.0+4044+ea5f78b1.4
Update to 1.15.7-10.module_el8.10.0+4044+ea5f78b1.4
mod_ldap AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
Update to 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
mod_md AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:2.0.8-8.module_el8.6.0+2872+fe0ff7aa
Update to 1:2.0.8-8.module_el8.6.0+2872+fe0ff7aa
mod_md AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:2.0.8-8.module_el8.6.0+3031+fb177b09
Update to 1:2.0.8-8.module_el8.6.0+3031+fb177b09
mod_proxy_html AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
Update to 1:2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
mod_session AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
Update to 2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
mod_ssl AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
Update to 1:2.4.37-65.module_el8.10.0+4044+ea5f78b1.5
Original sources
- https://access.redhat.com/errata/RHSA-2025:15123
- https://access.redhat.com/security/cve/CVE-2024-47252
- https://access.redhat.com/security/cve/CVE-2025-23048
- https://access.redhat.com/security/cve/CVE-2025-49630
- https://access.redhat.com/security/cve/CVE-2025-49812
- https://bugzilla.redhat.com/2374571
- https://bugzilla.redhat.com/2374576
- https://bugzilla.redhat.com/2374578
- https://bugzilla.redhat.com/2374580
- https://errata.almalinux.org/8/ALSA-2025-15123.html
- https://osv.dev/vulnerability/ALSA-2025:15123