ALSA-2026:47057
ALSA-2026:47057 · Important: nodejs:24 security update
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language. Security Fix(es): * brace-expansion: Brace-expansion: Denial of Service due to exponential-time complexity (CVE-2026-13149) * tar: Node-tar: Denial of Service via malformed tar archive header (CVE-2026-59874) * tar: node-tar: Denial of Service via crafted gzip bomb (CVE-2026-59873) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
nodejs AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 1:24.18.0-3.module_el9.8.0+286+9023ffdb
Update to 1:24.18.0-3.module_el9.8.0+286+9023ffdb
nodejs-devel AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 1:24.18.0-3.module_el9.8.0+286+9023ffdb
Update to 1:24.18.0-3.module_el9.8.0+286+9023ffdb
nodejs-docs AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 1:24.18.0-3.module_el9.8.0+286+9023ffdb
Update to 1:24.18.0-3.module_el9.8.0+286+9023ffdb
nodejs-full-i18n AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 1:24.18.0-3.module_el9.8.0+286+9023ffdb
Update to 1:24.18.0-3.module_el9.8.0+286+9023ffdb
nodejs-libs AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 1:24.18.0-3.module_el9.8.0+286+9023ffdb
Update to 1:24.18.0-3.module_el9.8.0+286+9023ffdb
nodejs-nodemon AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 3.1.14-2.module_el9.8.0+286+9023ffdb
Update to 3.1.14-2.module_el9.8.0+286+9023ffdb
nodejs-packaging AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 2021.06-6.module_el9.7.0+209+ecf6523e
Update to 2021.06-6.module_el9.7.0+209+ecf6523e
nodejs-packaging-bundler AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 2021.06-6.module_el9.7.0+209+ecf6523e
Update to 2021.06-6.module_el9.7.0+209+ecf6523e
npm AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 1:11.16.0-1.24.18.0.3.module_el9.8.0+286+9023ffdb
Update to 1:11.16.0-1.24.18.0.3.module_el9.8.0+286+9023ffdb
v8-13.6-devel AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 3:13.6.233.17-1.24.18.0.3.module_el9.8.0+286+9023ffdb
Update to 3:13.6.233.17-1.24.18.0.3.module_el9.8.0+286+9023ffdb
Original sources
- https://access.redhat.com/errata/RHSA-2026:47057
- https://access.redhat.com/security/cve/CVE-2026-13149
- https://access.redhat.com/security/cve/CVE-2026-59873
- https://access.redhat.com/security/cve/CVE-2026-59874
- https://bugzilla.redhat.com/2494813
- https://bugzilla.redhat.com/2498116
- https://bugzilla.redhat.com/2498120
- https://errata.almalinux.org/9/ALSA-2026-47057.html
- https://osv.dev/vulnerability/ALSA-2026:47057