ALSA-2026:47059
ALSA-2026:47059 · Important: nodejs:22 security update
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language. Security Fix(es): * brace-expansion: Brace-expansion: Denial of Service due to exponential-time complexity (CVE-2026-13149) * tar: Node-tar: Denial of Service via malformed tar archive header (CVE-2026-59874) * tar: node-tar: Denial of Service via crafted gzip bomb (CVE-2026-59873) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
nodejs AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:22.23.1-2.module_el8.10.0+4236+04bc75d9
Update to 1:22.23.1-2.module_el8.10.0+4236+04bc75d9
nodejs-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:22.23.1-2.module_el8.10.0+4236+04bc75d9
Update to 1:22.23.1-2.module_el8.10.0+4236+04bc75d9
nodejs-docs AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:22.23.1-2.module_el8.10.0+4236+04bc75d9
Update to 1:22.23.1-2.module_el8.10.0+4236+04bc75d9
nodejs-full-i18n AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:22.23.1-2.module_el8.10.0+4236+04bc75d9
Update to 1:22.23.1-2.module_el8.10.0+4236+04bc75d9
nodejs-libs AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:22.23.1-2.module_el8.10.0+4236+04bc75d9
Update to 1:22.23.1-2.module_el8.10.0+4236+04bc75d9
nodejs-nodemon AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 3.1.14-1.module_el8.10.0+4236+04bc75d9
Update to 3.1.14-1.module_el8.10.0+4236+04bc75d9
nodejs-packaging AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2021.06-6.module_el8.10.0+4158+e796f37f
Update to 2021.06-6.module_el8.10.0+4158+e796f37f
nodejs-packaging-bundler AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2021.06-6.module_el8.10.0+4158+e796f37f
Update to 2021.06-6.module_el8.10.0+4158+e796f37f
npm AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:10.9.8-1.22.23.1.2.module_el8.10.0+4236+04bc75d9
Update to 1:10.9.8-1.22.23.1.2.module_el8.10.0+4236+04bc75d9
v8-12.4-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 3:12.4.254.21-1.22.23.1.2.module_el8.10.0+4236+04bc75d9
Update to 3:12.4.254.21-1.22.23.1.2.module_el8.10.0+4236+04bc75d9
Original sources
- https://access.redhat.com/errata/RHSA-2026:47059
- https://access.redhat.com/security/cve/CVE-2026-13149
- https://access.redhat.com/security/cve/CVE-2026-59873
- https://access.redhat.com/security/cve/CVE-2026-59874
- https://bugzilla.redhat.com/2494813
- https://bugzilla.redhat.com/2498116
- https://bugzilla.redhat.com/2498120
- https://errata.almalinux.org/8/ALSA-2026-47059.html
- https://osv.dev/vulnerability/ALSA-2026:47059