ALSA-2026:47060
ALSA-2026:47060 · Important: nodejs:24 security update
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language. Security Fix(es): * brace-expansion: Brace-expansion: Denial of Service due to exponential-time complexity (CVE-2026-13149) * tar: Node-tar: Denial of Service via malformed tar archive header (CVE-2026-59874) * tar: node-tar: Denial of Service via crafted gzip bomb (CVE-2026-59873) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
nodejs AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:24.18.0-2.module_el8.10.0+4237+cde4efc3
Update to 1:24.18.0-2.module_el8.10.0+4237+cde4efc3
nodejs-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:24.18.0-2.module_el8.10.0+4237+cde4efc3
Update to 1:24.18.0-2.module_el8.10.0+4237+cde4efc3
nodejs-docs AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:24.18.0-2.module_el8.10.0+4237+cde4efc3
Update to 1:24.18.0-2.module_el8.10.0+4237+cde4efc3
nodejs-full-i18n AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:24.18.0-2.module_el8.10.0+4237+cde4efc3
Update to 1:24.18.0-2.module_el8.10.0+4237+cde4efc3
nodejs-libs AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:24.18.0-2.module_el8.10.0+4237+cde4efc3
Update to 1:24.18.0-2.module_el8.10.0+4237+cde4efc3
nodejs-nodemon AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 3.1.14-1.module_el8.10.0+4237+cde4efc3
Update to 3.1.14-1.module_el8.10.0+4237+cde4efc3
nodejs-packaging AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2021.06-6.module_el8.10.0+4086+70facd4a
Update to 2021.06-6.module_el8.10.0+4086+70facd4a
nodejs-packaging-bundler AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2021.06-6.module_el8.10.0+4086+70facd4a
Update to 2021.06-6.module_el8.10.0+4086+70facd4a
npm AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:11.16.0-1.24.18.0.2.module_el8.10.0+4237+cde4efc3
Update to 1:11.16.0-1.24.18.0.2.module_el8.10.0+4237+cde4efc3
v8-13.6-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 3:13.6.233.17-1.24.18.0.2.module_el8.10.0+4237+cde4efc3
Update to 3:13.6.233.17-1.24.18.0.2.module_el8.10.0+4237+cde4efc3
Original sources
- https://access.redhat.com/errata/RHSA-2026:47060
- https://access.redhat.com/security/cve/CVE-2026-13149
- https://access.redhat.com/security/cve/CVE-2026-59873
- https://access.redhat.com/security/cve/CVE-2026-59874
- https://bugzilla.redhat.com/2494813
- https://bugzilla.redhat.com/2498116
- https://bugzilla.redhat.com/2498120
- https://errata.almalinux.org/8/ALSA-2026-47060.html
- https://osv.dev/vulnerability/ALSA-2026:47060