ALSA-2026:54530
ALSA-2026:54530 · Important: nodejs:22 security update
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language. Security Fix(es): * sqlite: SQLite: Arbitrary code execution via crafted FTS5 full-text search data (CVE-2026-11822) * sqlite: SQLite: Arbitrary code execution and crash via heap-based buffer overflow in FTS5 (CVE-2026-11824) * brace-expansion: Brace-expansion: Denial of Service via memory exhaustion in expand() function (CVE-2026-14257) * brace-expansion: brace-expansion: Denial of Service via unbounded intermediate arrays (CVE-2026-69152) * ip-address: ip-address: Inconsistent IP address parsing leads to Server-Side Request Forgery (SSRF) and trust-boundary bypass (CVE-2026-69192) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
nodejs AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:22.23.1-3.module_el8.10.0+4251+b427b8a5
Update to 1:22.23.1-3.module_el8.10.0+4251+b427b8a5
nodejs-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:22.23.1-3.module_el8.10.0+4251+b427b8a5
Update to 1:22.23.1-3.module_el8.10.0+4251+b427b8a5
nodejs-docs AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:22.23.1-3.module_el8.10.0+4251+b427b8a5
Update to 1:22.23.1-3.module_el8.10.0+4251+b427b8a5
nodejs-full-i18n AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:22.23.1-3.module_el8.10.0+4251+b427b8a5
Update to 1:22.23.1-3.module_el8.10.0+4251+b427b8a5
nodejs-libs AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:22.23.1-3.module_el8.10.0+4251+b427b8a5
Update to 1:22.23.1-3.module_el8.10.0+4251+b427b8a5
nodejs-nodemon AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 3.1.14-2.module_el8.10.0+4252+aedd4c30
Update to 3.1.14-2.module_el8.10.0+4252+aedd4c30
nodejs-packaging AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2021.06-6.module_el8.10.0+4158+e796f37f
Update to 2021.06-6.module_el8.10.0+4158+e796f37f
nodejs-packaging-bundler AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 2021.06-6.module_el8.10.0+4158+e796f37f
Update to 2021.06-6.module_el8.10.0+4158+e796f37f
npm AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 1:10.9.8-1.22.23.1.3.module_el8.10.0+4251+b427b8a5
Update to 1:10.9.8-1.22.23.1.3.module_el8.10.0+4251+b427b8a5
v8-12.4-devel AlmaLinux:8
- Affected ranges
- ECOSYSTEM: < 3:12.4.254.21-1.22.23.1.3.module_el8.10.0+4251+b427b8a5
Update to 3:12.4.254.21-1.22.23.1.3.module_el8.10.0+4251+b427b8a5
Original sources
- https://access.redhat.com/errata/RHSA-2026:54530
- https://access.redhat.com/security/cve/CVE-2026-11822
- https://access.redhat.com/security/cve/CVE-2026-11824
- https://access.redhat.com/security/cve/CVE-2026-14257
- https://access.redhat.com/security/cve/CVE-2026-69152
- https://access.redhat.com/security/cve/CVE-2026-69192
- https://bugzilla.redhat.com/2506433
- https://bugzilla.redhat.com/2510722
- https://bugzilla.redhat.com/2510801
- https://errata.almalinux.org/8/ALSA-2026-54530.html
- https://osv.dev/vulnerability/ALSA-2026:54530