ALSA-2026:76750
ALSA-2026:76750 · Important: nodejs:22 security update
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language. Security Fix(es): * pacote: Pacote: Denial of Service via crafted spec.rawSpec value in addGitSha function (CVE-2026-9496) * undici: undici: Denial of Service via unrequested WebSocket subprotocol (CVE-2026-19534) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
nodejs AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 1:22.23.2-2.module_el9.8.0+322+f4aa738c
Update to 1:22.23.2-2.module_el9.8.0+322+f4aa738c
nodejs-devel AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 1:22.23.2-2.module_el9.8.0+322+f4aa738c
Update to 1:22.23.2-2.module_el9.8.0+322+f4aa738c
nodejs-docs AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 1:22.23.2-2.module_el9.8.0+322+f4aa738c
Update to 1:22.23.2-2.module_el9.8.0+322+f4aa738c
nodejs-full-i18n AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 1:22.23.2-2.module_el9.8.0+322+f4aa738c
Update to 1:22.23.2-2.module_el9.8.0+322+f4aa738c
nodejs-libs AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 1:22.23.2-2.module_el9.8.0+322+f4aa738c
Update to 1:22.23.2-2.module_el9.8.0+322+f4aa738c
nodejs-nodemon AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 3.1.14-2.module_el9.8.0+302+959ebcd4
Update to 3.1.14-2.module_el9.8.0+302+959ebcd4
nodejs-packaging AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 2021.06-6.module_el9.7.0+227+12323393
Update to 2021.06-6.module_el9.7.0+227+12323393
nodejs-packaging-bundler AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 2021.06-6.module_el9.7.0+227+12323393
Update to 2021.06-6.module_el9.7.0+227+12323393
npm AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 1:10.9.8-1.22.23.2.2.module_el9.8.0+322+f4aa738c
Update to 1:10.9.8-1.22.23.2.2.module_el9.8.0+322+f4aa738c
v8-12.4-devel AlmaLinux:9
- Affected ranges
- ECOSYSTEM: < 3:12.4.254.21-1.22.23.2.2.module_el9.8.0+322+f4aa738c
Update to 3:12.4.254.21-1.22.23.2.2.module_el9.8.0+322+f4aa738c
Original sources
- https://access.redhat.com/errata/RHSA-2026:76750
- https://access.redhat.com/security/cve/CVE-2026-19534
- https://access.redhat.com/security/cve/CVE-2026-9496
- https://bugzilla.redhat.com/2481394
- https://bugzilla.redhat.com/2528759
- https://errata.almalinux.org/9/ALSA-2026-76750.html
- https://osv.dev/vulnerability/ALSA-2026:76750