p PatchFirst

CVE-2002-0840

CVE-2002-0840

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Cross-site scripting (XSS) vulnerability in the default error page of Apache 2.0 before 2.0.43, and 1.3.x up to 1.3.26, when UseCanonicalName is "Off" and support for wildcard DNS is present, allows remote attackers to execute script as other web page visitors via the Host: header, a different vulnerability than CAN-2002-1157.

EPSS 95.1% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • apache2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.0.43-1

    Update to 2.0.43-1

  • apache2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.0.43-1

    Update to 2.0.43-1

  • apache2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.0.43-1

    Update to 2.0.43-1

Original sources

Check your server →