p PatchFirst

CVE-2002-1174

CVE-2002-1174

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Buffer overflows in Fetchmail 6.0.0 and earlier allow remote attackers to cause a denial of service (crash) or execute arbitrary code via (1) long headers that are not properly processed by the readheaders function, or (2) via long Received: headers, which are not properly parsed by the parse_received function.

EPSS 4.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • fetchmail Debian:12

    Affected ranges
    • ECOSYSTEM: < 6.1.0-1

    Update to 6.1.0-1

  • fetchmail Debian:13

    Affected ranges
    • ECOSYSTEM: < 6.1.0-1

    Update to 6.1.0-1

  • fetchmail Debian:14

    Affected ranges
    • ECOSYSTEM: < 6.1.0-1

    Update to 6.1.0-1

Original sources

Check your server →