p PatchFirst

CVE-2002-1383

CVE-2002-1383

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple integer overflows in Common Unix Printing System (CUPS) 1.1.14 through 1.1.17 allow remote attackers to execute arbitrary code via (1) the CUPSd HTTP interface, as demonstrated by vanilla-coke, and (2) the image handling code in CUPS filters, as demonstrated by mksun.

EPSS 9.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • cups Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.1.18-1

    Update to 1.1.18-1

  • cups Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.1.18-1

    Update to 1.1.18-1

  • cups Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.1.18-1

    Update to 1.1.18-1

Original sources

Check your server →