p PatchFirst

CVE-2003-0189

CVE-2003-0189

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The authentication module for Apache 2.0.40 through 2.0.45 on Unix does not properly handle threads safely when using the crypt_r or crypt functions, which allows remote attackers to cause a denial of service (failed Basic authentication with valid usernames and passwords) when a threaded MPM is used.

EPSS 15.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • apache2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.0.46

    Update to 2.0.46

  • apache2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.0.46

    Update to 2.0.46

  • apache2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.0.46

    Update to 2.0.46

Original sources

Check your server →