p PatchFirst

CVE-2003-0245

CVE-2003-0245

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Vulnerability in the apr_psprintf function in the Apache Portable Runtime (APR) library for Apache 2.0.37 through 2.0.45 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via long strings, as demonstrated using XML objects to mod_dav, and possibly other vectors.

EPSS 63.5% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • apache2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.0.46

    Update to 2.0.46

  • apache2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.0.46

    Update to 2.0.46

  • apache2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.0.46

    Update to 2.0.46

Original sources

Check your server →