p PatchFirst

CVE-2003-0689

CVE-2003-0689

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The getgrouplist function in GNU libc (glibc) 2.2.4 and earlier allows attackers to cause a denial of service (segmentation fault) and execute arbitrary code when a user is a member of a large number of groups, which can cause a buffer overflow.

EPSS 2.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • glibc Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.2.5

    Update to 2.2.5

  • glibc Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.2.5

    Update to 2.2.5

  • glibc Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.2.5

    Update to 2.2.5

Original sources

Check your server →