p PatchFirst

CVE-2004-1154

CVE-2004-1154

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Integer overflow in the Samba daemon (smbd) in Samba 2.x and 3.0.x through 3.0.9 allows remote authenticated users to cause a denial of service (application crash) and possibly execute arbitrary code via a Samba request with a large number of security descriptors that triggers a heap-based buffer overflow.

EPSS 13.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • samba Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.0.10-1

    Update to 3.0.10-1

  • samba Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.0.10-1

    Update to 3.0.10-1

  • samba Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.0.10-1

    Update to 3.0.10-1

Original sources

Check your server →