p PatchFirst

CVE-2004-1440

CVE-2004-1440

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple heap-based buffer overflows in the modpow function in PuTTY before 0.55 allow (1) remote attackers to execute arbitrary code via an SSH2 packet with a base argument that is larger than the mod argument, which causes the modpow function to write memory before the beginning of its buffer, and (2) remote malicious servers to cause a denial of service (client crash) and possibly execute arbitrary code via a large bignum during authentication.

EPSS 4.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • putty Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.56-1

    Update to 0.56-1

  • putty Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.56-1

    Update to 0.56-1

  • putty Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.56-1

    Update to 0.56-1

Original sources

Check your server →