p PatchFirst

CVE-2004-1453

CVE-2004-1453

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GNU glibc 2.3.4 before 2.3.4.20040619, 2.3.3 before 2.3.3.20040420, and 2.3.2 before 2.3.2-r10 does not restrict the use of LD_DEBUG for a setuid program, which allows local users to gain sensitive information, such as the list of symbols used by the program.

EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • glibc Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.3.5

    Update to 2.3.5

  • glibc Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.3.5

    Update to 2.3.5

  • glibc Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.3.5

    Update to 2.3.5

Original sources

Check your server →