p PatchFirst

CVE-2004-1487

CVE-2004-1487

This page contains facts from public vulnerability sources. Check the original advisory before updating.

wget 1.8.x and 1.9.x allows a remote malicious web server to overwrite certain files via a redirection URL containing a ".." that resolves to the IP address of the malicious server, which bypasses wget's filtering for ".." sequences.

EPSS 1.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wget Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.9.1-11

    Update to 1.9.1-11

  • wget Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.9.1-11

    Update to 1.9.1-11

  • wget Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.9.1-11

    Update to 1.9.1-11

Original sources

Check your server →