p PatchFirst

CVE-2004-1488

CVE-2004-1488

This page contains facts from public vulnerability sources. Check the original advisory before updating.

wget 1.8.x and 1.9.x does not filter or quote control characters when displaying HTTP responses to the terminal, which may allow remote malicious web servers to inject terminal escape sequences and execute arbitrary code.

EPSS 11.9% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wget Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.9.1-11

    Update to 1.9.1-11

  • wget Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.9.1-11

    Update to 1.9.1-11

  • wget Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.9.1-11

    Update to 1.9.1-11

Original sources

Check your server →