p PatchFirst

CVE-2005-0490

CVE-2005-0490

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple stack-based buffer overflows in libcURL and cURL 7.12.1, and possibly other versions, allow remote malicious web servers to execute arbitrary code via base64 encoded replies that exceed the intended buffer lengths when decoded, which is not properly handled by (1) the Curl_input_ntlm function in http_ntlm.c during NTLM authentication or (2) the Curl_krb_kauth and krb4_auth functions in krb4.c during Kerberos authentication.

CVSS 8.8 · High · EPSS 5.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • curl Debian:12

    Affected ranges
    • ECOSYSTEM: < 7.13.0-2

    Update to 7.13.0-2

  • curl Debian:13

    Affected ranges
    • ECOSYSTEM: < 7.13.0-2

    Update to 7.13.0-2

  • curl Debian:14

    Affected ranges
    • ECOSYSTEM: < 7.13.0-2

    Update to 7.13.0-2

Original sources

Check your server →